"Catalyst Anwendungsinstallation Installationspaket fehlgeschlagen"

47,630 Aufrufe
Gefragt 12, Feb 2013 in Windows 7 von Koka
Hallo,

vor Kurzem habe ich einen Sockel 939 PC mit SSD und W7 ausgestattet, zusammen mit einer HD 4670. Die Kiste läuft sehr gut, nur hat es ein Problem gegeben: Der AMD-Grafiktreiber installiert nur den Bildschirmtreiber und die HDMI-Audiotreiber, beim CCC = "AMD Vision Engine Control" und weiteren Programmteilen erscheint permanent "Catalyst Anwendungsinstallation Installationspaket fehlgeschlagen".

Da die Probleme - angeblich - mit dem .Net Framework zu tun haben, habe ich sogar eine Neuinstallation von W7 gemacht und versucht, direkt nach W7 und SP1 den Grafiktreiber zu installieren. Aber es ist immer das Selbe: Grafik- u. HDMI-Treiber werden installiert, das Controllcenter nicht. Es erscheint grundsätzlich die Fehlermeldung "...Installationspaket fehlgeschlagen". Das gilt auch für den Installationsmanager.
Unter Windows XP und dem entsprechenden XP32Bit-Treiber gibt es dagegen Null Probleme.

Nun habe ich einen gänzlich anderen PC vor mir: Sockel AM2+, HD 6450 und W7. Darauf wurde W7, das SP1 und dann der aktuelle 13.1-Grafiktreiber (13-1_vista_win7_win8_32-64_hydravision.exe) installiert und es ist schon wieder das Selbe: "Catalyst Anwendungsinstallation Installationspaket fehlgeschlagen". Installationsmanager und Control Center und diverse andere Programmteile fehlgeschlagen, Bildschirmtreiber und HDMI-Treiber ok.
Auch das CCC separat installiert nützt nichts.

Beim AMD Chipsatztreiber wird übrigens auch der Installationsmanager als fehlgeschlagen gemeldet, während die eigentlichen Treiber trotzdem installiert werden. Irgendwie verhalten sich AMD-Treiber, ob Chipsatz oder Grafik, einfach wie der letzte Schrott...

Da es sich um zwei völlig verschiedene Hardwaren handelt (einmal ziemlich alt, einmal rel. modern) und Treiber für XP einwandfrei zu installieren sind, Treiber für W7-64Bit aber nicht, frage ich mich langsam, ob es nicht daran liegt, ob AMD-Treiber mit W7-64Bit Probleme haben oder ob es an W7 liegt. So langsam bekomme ich eine Stinkwut auf diesen Softwaremist von AMD und würde am liebsten eine nVidia-Karte kaufen, obschon die Radeon ebenfalls neu ist.

Wer kann mir helfen? Ich würde einfach gerne das Catalyst Control Center installieren!

Gruß

48 Antworten

0 Punkte
Beantwortet 12, Feb 2013 von schmalhans
einfach des passende dotnet framework vorher installieren, fertig.

welches das passende ist, guckst du auf der ATI webseite nach
0 Punkte
Beantwortet 12, Feb 2013 von Koka
Ich habe schon alle .NET Framework Versionen ausprobiert (die vermeintlich richtige und auch die aktuellste Version), aber CCC wird trotzdem nicht installiert bzw. die Fehlermeldung ist nach wie vor die Selbe.
0 Punkte
Beantwortet 12, Feb 2013 von Koka
PS, die "passende" Version zum aktuellen Treiber wäre laut AMD:

AMD Catalyst Control Center requires Microsoft .NET4 Framework. Windows Vista and Windows 7 users may need to install the Microsoft .NET4 Framework as a prerequisite to use Catalyst Control Center.

Hier heruntergeladen und installiert: Fehlermeldung, s.o. ...
0 Punkte
Beantwortet 12, Feb 2013 von computerschrat Profi (17,942 Punkte)
Hallo Koka,

hast Du die Installation schon mal als Administrator gestartet? Also nicht mit Admin-Konto, sondern explizit das Inst-File rechts anklicken und dann "Ausführen als Administrator" wählen.
Gruß
computerschrat
0 Punkte
Beantwortet 12, Feb 2013 von Koka
explizit das Inst-File rechts anklicken und dann "Ausführen als Administrator" wählen.

Das gehörte bereits zu den ersten Aktionen. Bringt rein gar nichts.

Dieser AMD-Dreck macht mich wütend!
Ich installiere Windows (7-64), das SP1, das von AMD verlinkte 4er Framework (1x online versucht, 1x offline versucht...) und der Dreck meldet stur: "Catalyst Anwendungsinstallation Installationspaket fehlgeschlagen".
Ich kann auch das SP1 weglassen, und oder zuerst den Chipsatz installieren, oder das MS-Update, alles in beliebiger Reihenfolge, das Ergebnis heißt immer "Catalyst Anwendungsinstallation Installationspaket fehlgeschlagen" (ich bekomme bereits Pickel, wenn ich nur an diesen dummen Spruch nur denke).

Was kann ich denn machen? Das gibts doch gar nicht!?!
0 Punkte
Beantwortet 12, Feb 2013 von computerschrat Profi (17,942 Punkte)
Hallo Koka,

wenn man Herrn Google nach "Catalyst installation fehlgeschlagen" befragt, sieht man, dass Du nicht alleine bist.
Hier hat es jemand geschafft ->
extreme.pcgameshardware.de/grafikkarten/247198-amd-catalyst-12-11-beta8-installationspaket-fehlgeschlagen.html

Vielleicht hilft Dir die da beschriebene Vorgehensweise auch.

Gruß
computerschrat
0 Punkte
Beantwortet 12, Feb 2013 von Koka
Der hat nur "Treiberreste" enfernt und hat am Ende doch ein Fragezeichen. Ich dagegen habe eine Neuinstallation, da gibts keine Treiberreste zu beseitigen.
Ich kenne diese Seite! Und hundert weitere, mit nicht nachvollziehbarem und meist im Sand verlaufenden Ende.
Deshalb schreibe ich ja hier mein Problem selbst und hoffe auf jemand, der sich echt mit diesem Problem auskennt.
Bitte also keine weiteren Links mit den gewissen Stichworten, das habe ich natürlich längst schon selbst getan und ich hab sie alle durch!
0 Punkte
Beantwortet 13, Feb 2013 von win98professor Experte (1,273 Punkte)
Hallo,

das Kompatibilitätsproblem liegt meistens an der Programmierung. Bei der HD4670 setzt die Software des CCC im Grunde auf das etwas ältere Net Framework 1.1 + 2.0 auf. Es sollte aber fast immer mit dem Net Framework 2.0 SP1 funktionieren. Windows 7 bringt das Net Framework 3.5 SP1 von Haus aus mit. Dies enthält aber nur die Updates für die Versionen 2.0 - 3.5. Bei Problemen dieser Art gehe ich fast immer erst rückwärts. Lade dir für eine saubere Deinstallation das Framework Cleanup Tool Link runter. Anschließend lädst du das Komplettpaket 3.5 Link. Die Komplettversion (197,2 MB) enthält auch die Versionen 3.0 + 2.0 SP1). Die Installation funktioniert unter Windows 7 als Administrator. Danach den ATI-Treiber neu installieren. Mit etwas Glück sollten sich damit die Probleme bei der HD4670 lösen können. Ob das auch mit der HD 6450 funktioniert, kann ich dir nicht sagen, weil ich es dort selbst noch nicht getestet habe.

Gruß Micha
0 Punkte
Beantwortet 13, Feb 2013 von Koka
Hallo,

danke für dein Post! - ich will es nochmal deutlich machen: Das CCC aus dem (AGP-)Treiber für die HD 4670/AGP lies/lässt sich unter XP einwandfrei installieren. Ich weiß allerdings nicht mehr, welche Framework-Version(en) dabei installiert war!

Das Problem begann unter W7/SP1, als sich das CCC im entsprechenden 64Bit-Treiber für die HD 4670 nicht mehr installieren lies. Installiert sind das Framework 1.1 und 4.5, so wie es der Download des Aio-Runtimes-Pakets vorschlägt. Sereby geht wohl davon aus, dass damit alle in Frage kommenden Framweorks abgedeckt sind (!)

Im zweiten PC mit der HD 6450 läuft ebenfalls ein W7/SP1 + Framework 1.1 und 4.5 (vom Aio-Paket installiert), und hier gibt es wie gesagt das gleiche Problem mit CCC & Co (die eigentlichen Gerätetreiber sind wie immer nicht betroffen).

Was mich dabei wundert: zwischen den Treibern der beiden Grafikkarten - und damit auch dem CCC - liegen mehrere Jahre! Mit dem selben Problem! Da ist doch an meinem W7/SP1 was faul? Eine andere Logik will mir dabei nicht mehr einfallen.

Ich hab gerade den alten Rechner mit W7/SP1, HD 4670, aktuellem Treiber 13.1 (s. Eing.-Post), Framework 1.1 und 4.5 (Aio) vor mir - hier ein relevanter Ausschnitt aus dem Softwaremenü.

Was würdest Du machen? Das Framework 3.5 Komplettpaket parallel installieren? Oder erst das 4.5 plus 1.1 entfernen? Oder nur das 4.5 deinstallieren, dann aber nach der Inst. vom CCC wieder dazu? Ich habe ja schon so viel probiert, das glaubst Du gar nicht...

Gruß
0 Punkte
Beantwortet 13, Feb 2013 von randomnick
hast du mal in die verschiedenen TEMP ordner auf deinem pc geguckt. soweit ich weiss schreiben die setup programme allerhand logfiles weg, womit du dem problem vllt näher kommen kannst:


c:\Users\administrator\AppData\Local\Temp
c:\Users\<dein name>\AppData\Local\Temp
c:\windows\temp
C:\Windows\ServiceProfiles\LocalService\AppData\Local\Temp


usw.
...