Supportnet Computer
Planet of Tech

Supportnet / Forum / WindowsXP

XP und WLAN sicher ?





Frage

Hallo Supportnet - Besucher ! ich habe mal eine Frage an die Profis hier: Ich habe Win XP Pro mit SP2 und allen ? Sicherheitsupdates die automatisch geladen werden. Ich möchte über WLAN eine möglichst sichere Verbindung vom 2. Stock (mein PC) zur Fritzbox WLAN 7050 Fon im Erdgeschoss aufbauen, die wiederum über LAN-Kabel an den Server PC angeschlossen ist.. Die Fritzbox bzw. die Software von meinem USB Stick (DLink DWL-122) kann die folgenden Einstellungen verwenden: (eingestellte Werte in Klammern) Data Encryption: (Enabled) , Disabled Authentication: (Open), Shared, WPA, WPA-PSK Key Length: (128bits 104+24 13Ascii digits) , 128bits 104+24 26 Hexadecimal digits, 64bits 40+24 5Ascii digits, 64bits 40+24 10 Hexadecimal digits IEEE802.1x : (Disabled) , Enabled welche Kombinationen soll ich da einstellen bzw. welche sind am sichersten ? liebe Grüsse mausi

Antwort 1 von Das_Urmel

Data Encryption: (Enabled)
WPA-PSK
(128bits 104+24 13Ascii digits)
Groß/Klein Buchstaben mit Zahlen
IEEE802.1x : Enabled <- wobei das bei der Fritz egal ist

Trage deine MAC als berechtigt ein - sonst nichts.

Dann biste recht gut dabei, ist derzeit sicher.
mfg
Michael

Antwort 2 von mausi17

vielen Dank Urmel ,
wo soll ich meine "MAC" ? als berechtigt eintragen ?

liebe Grüsse

mausi

Antwort 3 von mausi17

irgendwie geht das nicht ?
ich bin jetzt wieder zurück zu ?WEP und habe die 13 HEX Zahlen 26Stellen) eingegeben die hinten auf der Fritzbox stehen 128bits 104+24 26 Hexadecimal digits und Authentification open - sonst kriege ich keinen connect.
Unten am PC (Konfig Fritz.box) kann man nicht so viele Dinge einstellen wie hier oben an der Dlink Software Wenn WPK dann TKIP ? auch wieder keine Ahnung ...
Wenn ich oben auf WPA-PSK stelle und unten auf nur WPA gehts nicht und auch nicht bei WPA TKIP ?
Was nun ?

liebe Grüsse

mausi

Antwort 4 von Das_Urmel

WPA-PSK
Datenverschlüsselung TKIP
Autentifizierung (am PC - Haken weg bei IEEE802.1X)
Netzwerkschlüssel bei beiden gleich)
Länge 128 Bit - schaue wo beide gleich einzustellen sind,
ASCII oder Hex ist eigentlich egal - nur eben bei beiden gleich.
An der Fritz - sofern möglich die gleichen Einstellungen vornehmen.
Wenn das nicht klappt - sind wohl die beiden, DLink und Fritz nicht völlig kompatibel - das gibt es auch - leider.

Wenn nicht machbar, wenigstens Authentifikation auf Shared
Es sollte dann ein Feld aufgehen, das den zu nutzenden Key anzeigt - von 1 bis 4 - am PC (Dlink) dann den gleichen einstellen und nicht auf Automatischem Key belassen.

Mit der MAC-Adresse - kannst du dann machen wenn alles soweit klappt - ist aber nicht zwingend nötig.

Zwischen nicht abgestimten Geräten kanns echt passieren, das nichts klappt - kenn ich auch, dann den gemeinsamen Nenner rausbasteln, der maximale Sicherheit bietet, Authentification Open wäre sehr schwach, besser shared.

Tut mir leid wenn es nicht so klappt
mfg
Michael

Antwort 5 von mausi17

Hallo Michael !

erst einmal ein gutes neues Jahr !
und vielen Dank für die Ratschläge.

nun, ich habe probiert und probiert, aber irgendwie funzt nichts mehr nachdem ich etwas umstelle !

mal der Reihe nach:
Ich habe an der Fritzbox generell nur 4 Möglichkeiten.
Entweder Verschlüsselung WEP mit 128bit oder 64bit Schlüssel, wobei der 128er Schlüssel mit der Box mitgeliefert wurde, und grundeingestellt war. (13Hex Zahlen, 26stellig)
oder Verschlüsselung mit WPK (PSK) mit Kennwort 13stellig HEX (da nahm ich versuchsweise immer denselben der bei der Box mitgeliefert wird)
oder mit AES.

Oben für den USB-Stick habe ich nur zum Teil dieselben Einstellungen gefunden, diese sind in meiner Frage schon erläutert worden, aber dennoch konnte ich damit keine Seite laden.

Ich hatte beim D-Link Air USB Utility (oben) folgendes eingestellt :

Authentication: WPA-PSK
wenn man WPA PSK einstellt werden ALLE anderen Optionseinstellungen grau und sind nicht mehr zu verstellen !
Also habe ich in der Konfiguration vorher auf OPEN gestellt und alle Daten eingegeben die Du vorschlugst, und danach auf WPA PSK umgestellt, nur dann sind die grau hinterlegten Daten so geblieben wie du geschrieben hast, ODER sind die für WPA PSK gar nicht mehr relevant ???
Data Encryption: Enabled
Key Length: 128bits 104+24 26 Hexadecimal digits
IEEE802.1x : Enabled
bei 1. - 4. jeweils den Schlüssel...
Man muss es mit Apply bestätigen;

Dann habe ich (nach Auskunft von AVM) unter IP Settings eingeben bei:
Assign the following IP Adress: 192.178.168.2
Subnet Mask: 255.255.255.0
Defaut Gateway: 192.178.168.1
und bei :
USE the following DNS Server Adress: 192.178.168.1
Jetzt gäbe es noch ein Authentication Config, wo ich aber nichts eingestellt habe!:
WPA Passphrase:
EAP TYPE: EAP-TLS LEAP EAP-TTLS PEAP
User Certificate: + Validate Server Certificate
User Name: Domain Name: Password: Confirm PW:
TTLS Identity:
dann unter Advanced kann man noch ein paar Dinge ein- umstellen:
Adhoc Channel: (6),7,8
Profile IP Settings: disabled
Power Mode: disabled
Launch at Startup: Enabled
Data Packet Parameter
Fragmentation Threshold: 2432
RTS Threshold: 2432

Dann kann ich noch auf SITE SURVEY wechseln, und
connecten oder refreshen oder unter Profile wieder auf die
Fritz!box klicken wo mir deren aktuell eingestellten Daten angezeigt werden. Ich bekomme auch immer einen Connect (laut Trayicon Drahtlose Netzwerkverbindungen und DLink), aber die Browser IE und Mozilla zeigen keine Seite an.

Bei Drahtlose Netzwerkverbindungen im Status kann ich ja die Datenübertragung mit ansehen. Es wird gesendet und empfangen. Beide "Wege" tickern aber nur mit etwa 100 bit Schritten voran, und eine Webseite wird scheinbar gar nicht geladen. Mir scheint es so als wäre das nur der interne Datenverkehr für den Connect der da grade noch läuft ?

Komischerweise stellte sich hier jedes mal nach der Umstellung bei Authentication auf WPA-PSK (wie oben angegeben) die Verschlüsselung um auf 64bit !?!?
OK, nachdem ich drei mal vergeblich versucht habe diese Einstellung auf 128bit zu bringen, bin ich nach unten und habe auch hier den Schlüssel nebst Werte auf 64bit eingestellt.
Trotzdem ist wieder nur ein Connect zustande gekommen, aber die Browser IE und Mozilla zeigen keine Seite an.

Wenn ich oben auf Shared einstelle komme ich auch nicht durch, nicht mal einen connect.

Was könnte ich falsch machen ?
Ist die Einstellung WEP und 128bit nicht sehr sicher ?

liebe Grüsse

mausi

Antwort 6 von Das_Urmel

Zitat:
Ist die Einstellung WEP und 128bit nicht sehr sicher ?

Ist nicht die beste und überholt.

Zitat:
wenn man WPA PSK einstellt werden ALLE anderen Optionseinstellungen grau und sind nicht mehr zu verstellen !

Richtig, dann gibt man nur noch ein Key ein - an beiden gleich und hat die bessere sichere Verbindung, normalerweise.

TKIP oder AES wäre der Algorhytmus, den sollten beide aber dann selbstätig erkennen.
Zitat:
als wäre das nur der interne Datenverkehr für den Connect der da grade noch läuft ?

Ja, die beiden Geräte kommen miteinander nicht klar,
handeln die Sicherheit nicht aus.
Zitat:
EAP TYPE: EAP-TLS
OK
Zitat:
User Certificate: + Validate Server Certificate

das nicht, ist kein Server (Radius) vorhanden

Stelle es am besten wieder so wie bei deiner Anfrage ein (ganz oben)
Ich muss da nochmal drüber nachdenken.
mfg
Michael

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: