Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Zellen zusammenzählen





Frage

möchte die Zellen zb.A1-A99 nur die ungeraden zellen zusammenzählen wie mache ich das. danke für eure hilfe. rolf

Antwort 1 von rainberg

Hallo Rolf,

=SUMMENPRODUKT((REST(ZEILE(1:99);2)<>0)*A1:A99)

Gruß
Rainer

Antwort 2 von Bischoff2000

super genau das brauchte ich wenn du mir jetzt noch schreiben könntest wie ich nur die geraden zahlen zusammen rechne wäre ich wunschlos glücklich.

mfg Rolf

Antwort 3 von rainberg

Hallo Rolf,

=SUMMENPRODUKT((REST(ZEILE(1:99);2)=0)*A1:A99)

Darauf könnte man selbst kommen :-) :-) :-)

Gruß
Rainer

Antwort 4 von Bischoff2000

Ja habe es schon selber rausgefunden war ganz leicht.

mfg Rolf

Antwort 5 von DoubleDee

Hi Hi

ich habe folgendes Problem.:

wenn ich Listen habe die jede Woche anders sind allerdings immer z.B. so aufgebaut sind, d.h. sie sehen zwar immer gleich aus nur der Inhalt ist jedes mal unterschiedlich.:

Wenn bei A Konto steht und bei B Name und bei C Nr.
dann habe ich z.b. bei Konto also A und B z.b. 5 mal das gleiche nur die C ändert sich aber in der Liste zeigt er mir A und B nur einmal bis ein neues Konto oder Name kommt dann gehtdas da auch so weiter.

Also ist meine Frage wie kriege ich es hin das er das Feld Konto und Das Feld Name jeweils um die stellen auffüllt bis das nächste Konto bzw. Name kommt?
denn z.B. soll Konto und Name immer da stehen und nicht nur einmal . Ich hoffe und danke auf/für schnelle Hilfe!!!

Gruß Dee

Antwort 6 von Saarbauer

Hallo,

ich würde eine neue Liste anlegen in der ab Zelle a2
steht =A1 und dies dann nach unterziehen soweit wie benötigt.

Somit steht in allen Zeilen der Wert von A1, sobald ich in die Zelle z.B. A7 einen neuen Wert eintrage steht der bis ans Ende usw.

Genauso würde ich mit der Spalte B verfahren.

Um die überflüssigen Daten in A und B nicht sichtbar werden zu lassen würde ich, über Bedingte Formatierung, bei alle leeren Zeilen in Spalte C den Text auf Hintergrundfarbe setzen. Damit erscheint nur bei ausgefüllter Spalte C Konto und Name.

Gruß


Helmut

Antwort 7 von DoubleDee

Hi Helmut,

erstmal danke und das klappt ja auch soweit wie du es beschrieben hast allerdings wenn ich jetzt die Daten aus der anderen Liste einfüge ist das mit dem =A1 z.B. einfach wieder weg und es sieht so aus wie vorher und ich kann ja nicht alles händisch eintragen.

Bzw. sollte es für die zukunft so sein das es immer automatisch so dargestellt wird wenn ich die Daten einfüge.

Vielleicht weißt du ja da auch rat!


Danke und Gruß

Dee

Antwort 8 von Saarbauer

Hallo,

das Funktioniert so nicht, da du mit den Einfügen Alles überschreibst. Es funktioniert nur bei einer Neuen Liste.

In dem Fall müßtest du zwischen den Feldern das manuell jedesmal unter der ausgefüllten Zelle beginnend nachtragen oder es über ein Makro automatisch nachtragen.

Gruß

Helmut

Antwort 9 von DoubleDee

Hi

ja und genau das ist die Frage wie? schreibe bzw. mache ich ein Makro bzw. wie müsste es aussehen?
Wo kann ich mir diese Infos holen oder so ähnlich denn ich habe mit Makros noch nie groß was zu tun gehabt!

Wenn du auch eine Antwort wüsstest wäre das auch cool!

Danke und Gruß

Dee

Antwort 10 von Saarbauer

Hallo,

so muß das Makro aussehen

Sub zeilen()

´Finden Makro
´ Makro am 04.07.2005 von Saarbauer
´Sheets("Bezeichnung Arbeitsblatt").Select
´ Es wird vorausgesetzt, dass in Zeile 1 die Spaltennamen stehen und dass die zu überprüfenden Werte in Spalte j stehen.
Range("c2").Select
While IsEmpty(ActiveCell) = False
ActiveCell.Offset(1, 0).Select
If Not IsEmpty(ActiveCell) Then
zeile = ActiveCell.Row()
Range("a" & zeile).Select
If IsEmpty(ActiveCell) Then
ActiveCell.Formula = "=A" & (zeile - 1)
End If
Range("b" & zeile).Select
If IsEmpty(ActiveCell) Then
ActiveCell.Formula = "=b" & (zeile - 1)
End If
Range("C" & zeile).Select
End If
Wend
End Sub

Kann rüberkopiert werden, jedoch sind dann bei den Kommentartexte die Hochkommas (sind hier Fett, Zeile 1 - 4) zu berichtigen, da diese nicht ordnungsgemäß übernommen werden.

Gruß

Helmut

Antwort 11 von Aliba

Hi Dee,

Du könntest das ganze auch mit einem 2. Tabellenblatt lösen.

Dein jetziges Blatt dient dann nur zur Erfassung, bzw. zum Import. (Nennen wir es mal Tabelle1)

im zweiten Tabellenblatt hast Du nun auch die Überschriften wie in Tabelle1

In A2 die Formel:
=WENN(Tabelle1!$C2="";"";WENN(Tabelle1!A2="";Tabelle1!A1;Tabelle1!A2))
Diese Formel dann noch nach B2 kopieren.
Dann beide Formeln soweit benötigt nach unten kopieren.
In C2 die Formel: =WENN(Tabelle1!C2="";"";Tabelle1!C2)

CU Aliba

Antwort 12 von DoubleDee

Hi Hi

erstmal danke für die mühe und die tolle mithilfe das ist echt klasse!

Und nun zu dir Helmut habe deinen Code rauskopiert usw. aber es will trotzdem net! Bzw. die Excel Tabelle verändert sich gar nicht!

Mache ich vielleicht etwas falsch? Muss der Code irgendwo an einen bestimmten Platz sein bzw. rein
Mit was bestimmten ausgeführt werden oder ähnliches?

Wie gesagt mit Makros habe ich null erfahrung!


Danke und Gruß

Antwort 13 von Saarbauer

Hallo,

das ganze wird etwas aufwendiger. Hast du schon mal ein Makro aufgezeichnet?
Vor dem Erstellen des Makro´s unbedingt Datensicherung durchführen.
Wenn nein, drücke "Alt""F11" dann klicke "VBAProjekt(......)" mit der rechten Maustaste, es öffnet sich ein Fenster "Einfügen""Modul". Es öffnet sich ein neues Fenster, an dessen oberen Rand in 2 Feldern "(Allgemein) (Deklaration)" steht . In das Darunterligende Feld, in den der Cusor blinkt, kopierst du die komplette Datei von

Sub zeilen()

End Sub


Das Wort "(Deklaration)" am oberen Rand ist durch
"zeilen". Anschliesend mit "F8" testen. Erforderliche Berichtigungen durchführen, s. Antwort 10.

"Visual Basic Editor" schließen und über "Extras"Makro""Makros""ausführen" das Makro komplett ausführen.

Gruß

Helmut

Antwort 14 von DoubleDee

Hi Hi

also ich habe jetzt alles gemacht was ihr mir so geschrieben habt und leider funktioniert das Makroanscheinend nicht! Denn egal wie die Liste bzw. Tabelle ändert sich keinen meter.


Gruß

Antwort 15 von Saarbauer

Hallo,

kannst du mir mal die Liste zumailen (send mir deine Mailadresse, erhälst dann meine) oder ist das nicht möglich.

Da du nicht reistriertes Mitglied (Member ) bist kann ich dir meine Adresse nicht direkt zukommen lassen.

Gruß

Helmut

Antwort 16 von DoubleDee

Also ich wollte dich genau das selbe fragen! ich gebe dir jetzt hier meine emailadresse und dann schick du mir grad mal deine denn ich bin grad dabei dir eine Beispiel Tabelle zu machen mit genauer erklärung was mein gewünschter effekt wäre.


Gruß


PS: djdoubledee2001@aol.com