Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

zeilenende erkennen?





Frage

Hallo an alle Kundigen! Ichhabe ein sicherlich ganz einfaches Problem. In Tabellenblatt ein ist eine Lsite die wöchtentlich ergänzt wird. In TAbellenblatt zwei ist die Auswertung. Also z.B. In Tb2 Soll er die summe errechnen A3:A50. Nun schreibe ich in der nächsten Woche weitere Zeilen in Tb1 hineine also in A51 und a52 usw. Um nun die auswertung in tb2 zu bekommen, muss ich jedes mal die Formel ändern und erweitern. Was muss ich tun, das er automatisch das ende der Zeile erkennt VIELEN DANK

Antwort 1 von coros

Hallo MiMa,

ob und wie man das mit einer Formel lösen kann, kann ich Dir leider nicht sagen, da ich eher der VBA-Mann (wer mich hier kennt und das dürften einige sein weiß das) und daher kommt hier auch nur eine VBA-Lösung. Mit nachfolgendem Makro wird Dir in das Tabellenblatt mit dem Namen "Tabelle2" in Zele A1 die Summenformel bei jedem Ausführen des Makros eingetragen, die immer den Bereich A2:Aletzte Zeile in Tabellenblatt "Tabelle1" berechnet. Kopiere das Makro in ein StandardModul und starte es über eine Schaltfläche.

Option Explicit

Sub Formel_autoanpassen()
Sheets("Tabelle2").Range("A1").FormulaLocal = _
"=SUMME(Tabelle1!A1:A" & Sheets("Tabelle1").Range("A65536").End(xlUp).Row & ")"
End Sub


Wenn das Blatt, in dem die Summenformel eingetragen werden soll, einen anderen Namen als "Tabelle2" hat, so musst Du in dem Makro dort wo "TAbelle2" steht Deinen Blattnamen eintragen. Genauso verhält es sich mit den Werten, die summiert werden sollen. Wenn die nicht in Tabelle1 stehen, dann den Namen überall dort wo "Tabelle1 steht anpassen.
Soll die Summenformel in eine andere Zelle als A1 eingetragen werden, so muss dort auch die entsprechende Zelle eingetragen werden.

Ich hoffe, Du kommst klar. Bei Fragen melde Dich bitte.

Solltest Du nicht wissen, wie Du den Code in Deine Datei bekommst, dann schau mal auf meiner HP in der Rubrik Anleitungen und dort dann in der Anleitungsnummer 3 nach. Dort stelle ich dazu eine bebilderte Anleitung zur Verfügung, die Dir sicherlich helfen wird.

MfG,
Oliver
Da hier der einzige Lohn für die Helfer eine Rückmeldung ist, wäre es nett, wenn Du ein
Feedback abgeben könntest, ob der Lösungsvorschlag Dein Problem gelöst hat.

Antwort 2 von nighty

hi all :)

eine möglichkeit :)

gruss nighty

=VERGLEICH("";A:A;-1)

Antwort 3 von nighty

hi all :)

oder letzte genutzte spalte :)

gruss nighty

=VERGLEICH("";1:1;-1)

Antwort 4 von fürLau

=SVERGLEICH(:-)

Antwort 5 von fürLau

=STIBIMMT(:-)

Antwort 6 von Risatara2

Ähhmmm... ich weiß jetzt nicht genau, wie das in deiner Tabelle aussieht, aber ist es dir nciht möglich, einfach eine

=Summe(A:A)

oder von mir aus auch eine

=Summe(A3:A65536)

zu schreiben? Oder anders gefragt, was ist denn in den Feldern A1 und A2 und in dem Feld A51 bevor es gefüllt wird drin?

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: