Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Excel Auf Daten von zweiter Tabelle beziehen





Frage

Hallo, ich wuerde mir gerne ein kleines Programm (auf Plan1),mit einer Tabelle im Hintergrund (Plan2), basteln. Hier der Aufbau: Plan2 (Tabelle) Hier ist eine Tabelle etwa in folgender Form hinterlegt. A B C D 1 1000 2000 3000 2 150 2.5 2.7 2.85 3 200 3.1 14.5 21.1 4 250 18 12 22.5 Plan1 (Eingabefelder) Ich wuerde nun gerne ein 'Programm' besteln was mir erlaubt durch zwei Eingabefelder den Wert aus der Tabelle in Plan 2 zu ermitteln. Hier ein Bespiel: Ich gebe in Plan 1 folgendes ein: in Feld A1: 2000 in feld B1: 250 in Feld C3 soll dann: 12 erscheinen. Es wird also die genaue Spalte und Zeile ermittelt und die 12 dann ausgespuckt. Meine Tabelle in Plan2 ist wesentlich groesser als das Beispiel oben dadurch wuerde mir so ein 'Programm' helfen. Gibt es eine Funktion fuer Excel die mir ermoeglicht anhand zweier Eingaben den exakten Wert aus der Tabelle (in Plan 2) zu ermitteln? Vielen Dank fuer Eure Hilfe!! Stefan

Antwort 1 von MixMax

Tabellenname!A3

Das Ausrufezeichen dient als unterscheidungsmerkmal wo der Tabellenname aufhört und die Zellenbezeichnung anfängt.

probier bei Bereichen aus einer Tabelle also

Tabellenname!A3:B6

Antwort 2 von Saarbauer

Hallo,

müsste mit Summenprodukt () machbar sein.

In C3

=Summenprodukt((Plan2!B1:Z1=Plan1!A1)*(Plan2! A2:A100=Plan1!B2)*(B2:Z100))

Ich habe die Größe der Tabelle mit Z-Spalten und 100-Zeilen angenommen habe

Gruß

Helmut

Antwort 3 von MixMax

also der verweis-befehl macht was ähnliches, allerdings müste man die wohl verschachteln einmal für horizontal einmal für vertikal... eventuell starte ich mal gleich meinen arbeitspc wo ich excel drauf habe

Antwort 4 von st_1919

Vielen Dank fuer Eure Antworten!

an Helmut:
Ich bin deinem Beispiel gefolgt:

Was bewirkten denn der letzte Ausdruck *(B2:Z100))
Und muss ich vor das B2 noch ein Plan2! einfuegen?

Bei mir wird im Feld C3 folgender Fehler angezeigt:
#N/A

Fass kann falsch sein?
Vielen Dank, Stefan

Antwort 5 von MixMax

saar - fast richtig aber guter anstoß - natürlich muss man das mit summenprodukt machen...

=SUMMENPRODUKT((Plan2!B1:Z1=A1)*(Plan2!A2:A500=A2)*(Plan2!B2:Z500))


habe
Plan1!A1 = 1000
Plan1!A2 = 250
Plan1!A3 = die Formel (kommt 18 raus)

Plan2 wie in der Fragestellung

  • *edit* Plan nicht Tabelle wie in der Fragestellung geändert.[/url]

  • Antwort 6 von st_1919

    Vielen Dank, Saarbauer, MixMax!

    Jetzt klappt alles 100%
    Ihr habt mir sehr geholfen!

    Gruesse, Stefan