Supportnet Computer Supportnet Games Supportnet Kochen Explipedia
Login: guestBesucher online: 360
Supportnet Computerforum
SUPPORT
Home
Forum
Tipps & Infos
Blitz Angebote
Members
Hilfe
Video

TOP THEMEN
SSD Test
Alles über SSDs

Android Tipps
iPad Tipps
Google Tipps
Windows 8 FAQ
Windows 7 FAQ
E-Mail FAQ
Netzwerk FAQ
Festplatten FAQ
Datenrettung FAQ
Bildbearbeitung FAQ

Top iPhone Apps
Computer Einsteiger
Die 5 besten...
Explipedia
Themen
Direktlinks

Neue Einträge
News einsenden News einschicken
Tipps einsenden Tipp einschicken

SN-LINKS

Suche
Befreundete Seiten
Top Seiten

Supportnet/Forum/Windows98



Supportnet/Forum/Windows98
von Windows98-Fan vom 21.05.2015, 07:37 Diese Seite den Supportnet Favoriten hinzufügen  Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden


Windows 98 Desktop-Hintergrund wechselt nicht mehr automatisch bei Auswahl eines anderen Themes aus den Desktop-Motiven

 (3203 Hits)

Ich habe auf einem alten Laptop Windows 98 SE installiert, damit ich meine alte Software noch einmal wiederbeleben kann ;-)

In dem Zusammenhang habe ich auch das inoffizielle Service Pack 2.1 d installiert.

Sowei so gut.

Dabei ist mir aufgefallen, dass ich die in Windows 98 SE inkludierten Desktop-Motive z. B. Computer-Innenleben zwar auswählen kann,

es wird alles bis auf den jeweiligen Desktop-Hintergrund angepasst.

Das heißt, Sound, Mauszeiger, Farbschema usw. ändern sich entsprechend. Aber Der Desktop zeigt nicht das entsprechende Hintergrundbild an, sondern

lediglich einen einfarbigen Hintergrund.

Das Problem trat erst nach der Installation des inoffiziellen Service Pack 2.1 d auf.

Ich habe dann einmal verglichen wo der Unterschied liegt.

Windows 98 SE ohne inoffizielles Service Pack:

Im Ordner C:\Windows gibt es eine Datei mit dem Namen "Plus.jpg", die dann auch unter Systemsteuerung -> Anzeige -> Hintergrund automatisch zur Auswahl steht und immer das entsprechende Hintergrund-Bild enthält zum ausgewählten Desktop-Motiv Thema.

Windows 98 SE nach der inoffiziellen Service Pack Installation:

Im Ordner C:\Windows fehlt diese Datei. Dementsprechend steht sie auch nicht automatisch zur Auswahl.

Wenn ich nun ein Deskotp-Theme auswähle muss ich von Hand den entsprechenden Hintergrund unter Systemsteuerung -> Anzeige -> Hintergrund

auswählen. Ich greife dann mit Durchsuchen auf die JPG-Dateien im Ordner c:\Programme\Plus!\ zu.

Anmerkung:

Es handelt sich um die in Windows 98 SE inkludierten Desktop-Motive. Ich habe keine seperate Installation von einer Windows 98 PLUS! CD gemacht.

Auch habe ich bereits die Desktop-Motive unter Systemsteuerung -> Software mehrmals inaktiviert und wieder aktiviert.

Hat jemand eine Idee oder das gleiche Problem.

Vielleicht ist es ein fehlerhafter Eintrag in der Registry, der verhindert, dass das jeweilige Hintergrund-Bild der Desktop-Themes mit dem Namen Plus.jpg im Ordner c:\Windows\ abgelegt wird???


Antwort schreiben 50 Bonuspunkte

Antworten...
Antwort 1 von Lasslo vom 21.05.2015, 15:53 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hi,
vielleicht stimmt der Pfad zur Plus.jpg nicht. Kopiere sie mal in den Pfad "c:\Programme\Plus!". Vielleicht klappt es dann.


Antwort noch nicht bewertet
Antwort 2 von win98professor vom 21.05.2015, 16:09 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo Windows98-Fan,

bei der Plus!.bmp handelt es sich um eine temporäre Datei, die über die Systemsteuerung > Desktop Motive automatisch in C:/Windows erstellt und in der Anzeige eingebunden wird, sobald ein entsprechendes Desktop Thema ausgewählt wurde. Da sie bei jedem Wechsel des Motives automatisch neu erstellt wird, kann sie auch jederzeit manuell gelöscht werden. Das Service Pack 2.1d installiert in der Systemsteuerung Tweak UI 1.33 (wenn bei der Installation ausgewählt, sonst nachträglich installierbar). Öffne dort mal den Reiter IE und schau nach, ob dort die Optionen "Erlaubt Änderungen am Active Desktop" und "Erlaubt den Activ Desktop ein- und auszuschalten aktiviert sind".

Gruß


Antwort noch nicht bewertet Als gute Antwort bewerten
Diese Antwort hat mein Problem gelöst
Antwort 3 von Windows98Fan vom 22.05.2015, 07:25 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Zitat:
Hallo Windows98-Fan,

bei der Plus!.bmp handelt es sich um eine temporäre Datei, die über die Systemsteuerung > Desktop Motive automatisch in C:/Windows erstellt und in der Anzeige eingebunden wird, sobald ein entsprechendes Desktop Thema ausgewählt wurde. Da sie bei jedem Wechsel des Motives automatisch neu erstellt wird, kann sie auch jederzeit manuell gelöscht werden. Das Service Pack 2.1d installiert in der Systemsteuerung Tweak UI 1.33 (wenn bei der Installation ausgewählt, sonst nachträglich installierbar). Öffne dort mal den Reiter IE und schau nach, ob dort die Optionen "Erlaubt Änderungen am Active Desktop" und "Erlaubt den Activ Desktop ein- und auszuschalten aktiviert sind".

Gruß


Ich habe mal das Tweak UI 1.33 nachinstalliert und nachgeschaut.
Die Haken sitzen überall an den entsprechenden Stellen.
Meines erachtens arbeitet "Desktop-Motive" nicht korrekt,
da ja keine PLUS!.bmp erzeugt und unter c:\windows abgelegt wird.
In Folge dessen wird unter Systemsteuerung > Anzeige > Hintergrund
auch immer nur "Kein" vorbelegt.

Aber mehr als die Desktopmotive zu deinstallieren und wieder zu installieren kann man doch nicht tun.

Ich habe das ganze Szenario auch auf einem anderen Windows 98 PC nachgestellt. Gleiches Problem.


Antwort noch nicht bewertet
Antwort 4 von win98professor vom 22.05.2015, 13:40 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo Windows98Fan,

wenn das Problem auf einem anderen PC ebenfalls auftritt, dann tippe ich entweder auf eine defekte Themes.exe (112 kb, Version 4.40.500), oder beschädigte Hintergrund Jpeg's auf der gepressten Installations-CD. Es gab früher einige Programme und auch Spiele, die diverse Bmp's oder Jpeg's hatten, die vom System nicht sauber verarbeitet werden konnten. Hat man die Bmp's dann über Paint oder die Jpeg's über den Internet Explorer geöffnet, neu abgespeichert und dann damit das Original ersetzt, konnte man das Problem so oftmals beheben. Also einfach mal das entsprechende Hintergrundbild im Plus! Ordner mit dem Explorer öffnen und neu abspeichern. Anschließend mit dem neu erstellten Jpeg das Original im PLUS! Ordner ersetzen und neu testen. Vielleicht hast du ja Glück das es dann wieder funktioniert.

Gruß


Antwort noch nicht bewertet Als gute Antwort bewerten
Diese Antwort hat mein Problem gelöst
Antwort 5 von win98professor vom 22.05.2015, 14:01 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo nochmal,

da fällt mir gerade auf, hast du im Windows Setup > Zubehör > Paint installiert? Es könnte sein, das die Themes.exe sonst aus dem Jpeg keine BMP Datei erstellen kann.

Gruß


Antwort noch nicht bewertet Als gute Antwort bewerten
Diese Antwort hat mein Problem gelöst
Antwort 6 von Windows98-Fan vom 22.05.2015, 20:17 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Ich vermute zwischenzeitlich das es an der Datei
jpegim32.flt liegt.
Die wird nämlich beim Service Pack durch eine Version von 2005
ersetzt.
Mir liegt leider jetzt nich das Orginal von 1999 vor.
Sonst würde ich mal testen.

Habe gelesen, dass die Datei auch im Rahmen der Office 97 Probleme mit Themes.exe verursacht.


Antwort noch nicht bewertet
Antwort 7 von Windows-Fan98 vom 22.05.2015, 21:18 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Lösung!



Nach langer Recherche bin ich auf den Verursacher gestoßen und habe das Problem lösen können.

Schuld ist wie gesagt die Datei JPEGIM32.FLT die durch das inoffizielle Patch 2.1 d überschrieben wird.
Ursprünglich von 1999 mit einer Version von 2005

Einfach die ursprüngliche Datei von der Windows 98 CD exthrahieren mit sfc.exe und durch die neuere durch die ältere Version ersetzen.

Folgender Link bringt die Lösung:
http://smallbusiness.support.microsoft.com/de-de/kb/220866

Kleine Abweichung allerdings zur Beschreibung von Microsoft...
Die ursprüngliche Datei nicht in c:\Programme\Gemeinsame Dateien\Microsoft Shared\Grphflt extrahieren sondern in den Ordner
c:\windows\msapps\grphflt

Dann läufts wieder.


Antwort noch nicht bewertet
Antwort 8 von win98professor vom 23.05.2015, 13:25 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo Windows98-Fan,

nachdem ich eine Win98 SE Neuinstallation in einer VM gemacht habe, konnte ich dein Problem reproduzieren. Anscheinend ist Microsoft da der gleiche Fehler wie mir unterlaufen. In meinen Win98 SE Systemen habe ich überall zwei verschiedene Jpegim32.flt Dateien. Zum einen die aktualisierte Datei in C:\ Windows \ Msapps \ Grphflt mit 152 kb, die bei mir überall einwandfrei mit den Desktop Motiven funktioniert, zum anderen in C:\ Windows \ Programme \ Microsoft Shared \ Grphflt eine Jpegim32.flt mit 153 kb.

Dieser Pfad wird von MS Office Programmen wie z. B. MS Office oder MS Outlook angelegt. Beide tragen die gleiche Versionsnummer 2003.1100.5531, aber der Unterschied liegt in der Sprachausführung. Die Jpegim32.flt mit 152 kb vom Service Pack 2.1d im Ordner Msapps \ Grphflt liegt in der englischen Version vor. Die Jpegim32.flt mit 153 kb im Ordner Microsoft Shared / Grphflt ist in der deutschen Sprache. Überschreibe ich in der VM die englische Datei mit der deutschen Ausführung funktionieren die Desktop Motive reibungslos.

Installiert man aber, wie auch bei mir, vorab MS Office Komponenten wie z. B. MS Outlook oder MS Office, funktioniert auch die englische Jpegim32.flt Version des Service Packs. Es ist dann sogar egal in welchem Ordner sie liegt. Löscht man z. B. die Datei in Msapps, greift die Themes.exe dann auch automatisch auf die andere Datei zu und umgekehrt.

Leider warnt das Service Pack 2.1d erst bei installierten MS Office Komponenten vor dem Sprachversionskonflikt, weil dann die gleichen Versionsnummern vorliegen. Ich habe Creopard bereits eine Nachricht mit der deutschen Jpegim32.flt im Anhang gesendet und auf diesen Thread verwiesen, damit die Datei entsprechend ersetzt wird und das Problem bei einer Standardinstallation nicht mehr auftreten kann.

Danke für die Fehlerbeschreibung und die gefundene Lösung.

Gruß Micha


Antwort noch nicht bewertet Als gute Antwort bewerten
Diese Antwort hat mein Problem gelöst




Hinweis
Diese Frage ist schon etwas älter, Sie können daher nicht mehr auf sie antworten. Sollte Ihre Frage noch nicht gelöst sein, stellen Sie einfach eine neue Frage im Forum.

MACHEN SIE IHRE WEBSITE ATTRAKTIVER
Sie haben eine eigene Website und wollen Ihre Besucher auf den Supportnet-Service aufmerksam machen? Kopieren Sie einfach den Quellcode in Ihre Seite und jeder Besucher Ihrer Seite kann direkt auf die Supportnet-Datenbank zugreifen.

My Supportnet


SUCHE

Gruppen im Forum
Betriebsysteme
Software
Hardware
Netzwerk
Programmierung
Sonstiges

Impressum © 1997-2015 SupportNet
Version: supportware 1.8.230E / 18.10.2010, Startzeit:Tue Oct 17 18:17:53 2017