Supportnet Computer Supportnet Games Supportnet Kochen Explipedia
Login: guestBesucher online: 133
Supportnet Computerforum
SUPPORT
Home
Forum
Tipps & Infos
Blitz Angebote
Members
Hilfe
Video

TOP THEMEN
SSD Test
Alles über SSDs

Android Tipps
iPad Tipps
Google Tipps
Windows 8 FAQ
Windows 7 FAQ
E-Mail FAQ
Netzwerk FAQ
Festplatten FAQ
Datenrettung FAQ
Bildbearbeitung FAQ

Top iPhone Apps
Computer Einsteiger
Die 5 besten...
Explipedia
Themen
Direktlinks

Neue Einträge
News einsenden News einschicken
Tipps einsenden Tipp einschicken

SN-LINKS

Suche
Befreundete Seiten
Top Seiten

Supportnet/Forum/Tabellenkalkulation



Supportnet/Forum/Tabellenkalkulation
von Mario1991bmg vom 06.01.2017, 08:29 Diese Seite den Supportnet Favoriten hinzufügen  Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden


Datenabfrage aus mehreren Tabellenblättern

 (245 Hits)

Hallo zusammen,

ich muss eine Tabelle erstellen, in der eine Statistik für mehrere
Personen geführt wird .Auf dem ersten Tabellenblatt ist nun eine
Auflistung der einzelnen Tage untereinander. Rechts davon sind die
"Kriterien" die sich ebenfalls auf jedem Blatt befinden. Nun möchte ich,
dass diese Kriterien von den einzelnen Blättern in die
"Gesamtübersicht" (in Abhängigkeit der jeweiligen Person) übertragen
werden. Weiß jemand wie das geht?

Bin um jede Antwort dankbar.

Hier noch zwei Screenshots von der Datei.

http://www.pic-upload.de/view-32432068/Datumsblatt.jpg.html

http://www.pic-upload.de/view-32432069/Gesamt.jpg.html


Antwort schreiben 50 Bonuspunkte

Antworten...
Antwort 1 von M.O. vom 06.01.2017, 10:36 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo Mario,

warum legt man nicht für die einzelnen Personen ein Blatt wie Gesamt an?

Aber zu deiner Frage. Hier die Formel für die Zelle B4:
=WVERWEIS($B$1;'01.01.2017'!$B$1:$I$7;VERGLEICH(B$3;'01.01.2017'!$A$1:$A$7;0);FALSCH)
Die Bereiche musst du noch auf deine Verhältnisse anpassen.
Die Formel kannst du soweit wie benötigt nach links und auch nach unten ziehen. Allerdings musst du dann den Verweis auf die Arbeitsblätter jeweils anpassen.
Soll das auch automatisch gehen, so kannst du das mit der Funktion INDIREKT lösen (hier wieder die Formel für B4):
=WVERWEIS($B$1;INDIREKT("'"&TEXT($A4;"TT.MM.JJJJ")&"'!$B$1:$E$7");VERGLEICH(B$3;INDIREKT("'"&TEXT($A4;"TT.MM.JJJJ")&"'!$A$1:$A$7");0);FALSCH)

Die Funktion INDIREKT hat aber den großen Nachtteil, dass sie volatil ist, d.h. sie wird immer neuberechntet, nach jeder Eingabe. Selbst dann, wenn sie in einer anderen geöffneten Arbeitsmappe steht! Es könnte also aufgrund des Aufbau deiner Arbeitsmappe zu Performanceproblemen kommen.

Die Namen und die Begriffe in der Zeile 3 im Blatt "Gesamt" müssen mit den Namen und Begriffen in Spalte A in den einzelnen Datumsblättern übereinstimmen.

Gruß

M.O.


Antwort noch nicht bewertet Als gute Antwort bewerten
Diese Antwort hat mein Problem gelöst
Antwort 2 von Mario1991bmg vom 06.01.2017, 10:58 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo M.O.,

vielen Dank für deine Lösung, es hat so auf Anhieb funktioniert. :-) Der Hinweis bezüglich der Performanceprobleme ist berechtigt, es dauert
teilweise schon etwas, bis die "Berechnung" auf meinem PC durch ist.

Deine Frage ist durchaus berechtigt. Ich denke, dass es so sogar viel übersichtlicher und einfacher ist... ;-)

Gruß

Mario


Antwort noch nicht bewertet
Antwort 3 von HoRcRuX vom 06.01.2017, 11:00 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo Mario,
wenn du die Struktur deiner Tabellen anpasst, am Besten indem die Personen in den Datumsblättern in den Zeilen stehen und die Spalten jetzt
„schulische Entwicklung“, „Gesundheit“ etc. werden könntest du mit etwas aufwand folgendermaßen vorgehen:
Für die Gesamt Tabelle:

In Zelle B1 eine Dropdownliste erstellen (Daten-> Datenüberprüfung-> Liste)

Und für jeden einzelnen Tag per SVERWEIS nach dem Namen in B1 suchen lassen, im Bereich des jeweiligen Tagesregisters

Das würde dann für die zelle:
B4 ungefähr so aussehen =SVERWEIS($B$1;'01.01.2017'!$A$2:$G$100;2)
C4 =SVERWEIS($B$1;'01.01.2017'!$A$2:$G$100;3)

Das analog bis G4 =SVERWEIS($B$1;'01.01.2017'!$A$2:$G$100;7)
Einfach die Spaltenangabe immer ändern.
Nun müsste man das für jedes neue Datumsregister wiederholen.
Macht Arbeit aber geht 
Viele Grüße

Christian


Antwort noch nicht bewertet




Hinweis
Diese Frage ist schon etwas älter, Sie können daher nicht mehr auf sie antworten. Sollte Ihre Frage noch nicht gelöst sein, stellen Sie einfach eine neue Frage im Forum.

MACHEN SIE IHRE WEBSITE ATTRAKTIVER
Sie haben eine eigene Website und wollen Ihre Besucher auf den Supportnet-Service aufmerksam machen? Kopieren Sie einfach den Quellcode in Ihre Seite und jeder Besucher Ihrer Seite kann direkt auf die Supportnet-Datenbank zugreifen.

My Supportnet


SUCHE

Gruppen im Forum
Betriebsysteme
Software
Hardware
Netzwerk
Programmierung
Sonstiges

Impressum © 1997-2015 SupportNet
Version: supportware 1.8.230E / 18.10.2010, Startzeit:Mon Sep 25 00:38:08 2017