Supportnet Computer Supportnet Games Supportnet Kochen Explipedia
Login: guestBesucher online: 111
Supportnet Computerforum
SUPPORT
Home
Forum
Tipps & Infos
Blitz Angebote
Members
Hilfe
Video

TOP THEMEN
SSD Test
Alles über SSDs

Android Tipps
iPad Tipps
Google Tipps
Windows 8 FAQ
Windows 7 FAQ
E-Mail FAQ
Netzwerk FAQ
Festplatten FAQ
Datenrettung FAQ
Bildbearbeitung FAQ

Top iPhone Apps
Computer Einsteiger
Die 5 besten...
Explipedia
Themen
Direktlinks

Neue Einträge
News einsenden News einschicken
Tipps einsenden Tipp einschicken

SN-LINKS

Suche
Befreundete Seiten
Top Seiten

Supportnet/Forum/Tabellenkalkulation



Supportnet/Forum/Tabellenkalkulation
von energun223 vom 05.02.2017, 21:01 Diese Seite den Supportnet Favoriten hinzufügen  Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden


nur richtige Zahlen kein Datum zählen

 (443 Hits)

Hallo zusammen,

in meiner Tabelle wird die Spalte D2 bis D9 mit M1 verglichen bei Übereinstimmung sollen die Werte jedoch nicht das MHD gezählt werden. Es funktioniert aber nur bedingt da es mehrere Spalten sind.


folgende Formel nutzte ich als erstes:

=SUMMENPRODUKT(((G2:G9)*(D2:D9=M1)))


hier kommt dann 3 raus was auch stimmt da ich den Bereich direkt angebe. Jetzt habe ich es für die ganze Tabelle probiert mit folgender Formel:

=SUMMENPRODUKT((ISTZAHL(F2:K9)*(D2:D9=M1)))


jetzt kommt 14 raus obwohl die Summe eigentlich 7 lauten müsste. ISTZAHL weil ich dachte das sie tatsächlich nur die Mengen zählt aber das Datum ist ja auch eine Zahl. :-)

Ich möchte also nur die Mengen nicht die MHD zählen. Hat jemand vielleicht eine Formel parat?

Im Anhang meine Tabelle zum besseren Verständniss.

https://www.dropbox.com/s/4l8vlp7tk636gsu/summe.xlsx?dl=0

Gruß
energun222


Antwort schreiben 50 Bonuspunkte

Antworten...
Antwort 1 von energun223 vom 05.02.2017, 21:31 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo zusammen,

kleiner Nachtrag, die 2. Formel ist auch Murks. Sorry für Doppelpost.

Gruß
energun222


Antwort noch nicht bewertet
Antwort 2 von rainberg vom 06.02.2017, 07:11 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo,

Formel für M2:

=SUMMENPRODUKT((REST(SPALTE($F:$K);2)*
($D$2:$D$1000=M$1)*($F$2:$K$1000)))

Formel für N2:

=SUMMENPRODUKT((REST(SPALTE($F:$K);2)*($D$2:$D$1000=N$1)*($F$2:$K$1000)))

Die Zeilenbezüge beider Formeln sind anzupassen.

Gruß
Rainer


Antwort noch nicht bewertet Als gute Antwort bewerten
Diese Antwort hat mein Problem gelöst
Antwort 3 von energun223 vom 06.02.2017, 15:23 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo rainberg,

funktioniert Super Dank Dir. Wieder was dazu gelernt!

Gruß
energun222


Antwort noch nicht bewertet
Antwort 4 von energun223 vom 21.03.2017, 13:46 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo rainberg,

wenn ich hinter der Spalte D also dem Typ eine Spalte hinzufüge passen sich zwar die Bezüge an aber es kommt nicht 7 sondern 299641 raus obwohl der Bezug richtig ist.

An was kann das denn liegen?

Gruß
energun222


Antwort noch nicht bewertet
Antwort 5 von rainberg vom 21.03.2017, 14:29 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo,

ändere die Formeln wie folgt

N2:
=SUMMENPRODUKT((REST(SPALTE($G:$L);2)=0)*($D$2:$D$1000=N$1)*($G$2:$L$1000))


O2:
=SUMMENPRODUKT((REST(SPALTE($G:$L);2)=0)*($D$2:$D$1000=O$1)*($G$2:$L$1000))


Gruß
Rainer


Antwort noch nicht bewertet Als gute Antwort bewerten
Diese Antwort hat mein Problem gelöst
Antwort 6 von energun223 vom 22.03.2017, 12:07 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo rainberg,

funktioniert natürlich. Danke schön! Der einzigste Unterschied ist also nur dieser Teil?

=0)


Was macht denn dieses Teilstück aus? Würde es gerne verstehen.

Gruß
energun222


Antwort noch nicht bewertet
Antwort 7 von rainberg vom 23.03.2017, 07:22 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo,

Was macht denn dieses Teilstück aus? Würde es gerne verstehen.

.... dann vertiefe dich mal intensiv in die Funktion =REST()

Beispiel:
Schreibe in A1 eines leeren Arbeitsblattes

=REST(SPALTE();2),

ziehe diese Formel über mehrere Spalten nach rechts und betrachte die Ergebnisse.
Wiederhole diese Prozedur indem du die 2 in der Formel durch eine 3 oder 4 oder eine andere Ziffer ersetzt und betrachte wiederum die Ergebnisse.

Damit kannst du nun steuern, mit welchen Spalten SUMMENNPRODUKT() rechnen soll. (Jede 2-te, 3-te, 4-te, x-te Salte)

Gruß
Rainer


Antwort noch nicht bewertet Als gute Antwort bewerten
Diese Antwort hat mein Problem gelöst
Antwort 8 von energun223 vom 24.03.2017, 00:14 Mißbrauch, Beleidigungen und Blödsinn den Moderatoren melden

Hallo,

werd mich mal rein lesen. Dank dir.

Gruß
energun222


Antwort noch nicht bewertet




Hinweis
Diese Frage ist schon etwas älter, Sie können daher nicht mehr auf sie antworten. Sollte Ihre Frage noch nicht gelöst sein, stellen Sie einfach eine neue Frage im Forum.

MACHEN SIE IHRE WEBSITE ATTRAKTIVER
Sie haben eine eigene Website und wollen Ihre Besucher auf den Supportnet-Service aufmerksam machen? Kopieren Sie einfach den Quellcode in Ihre Seite und jeder Besucher Ihrer Seite kann direkt auf die Supportnet-Datenbank zugreifen.

My Supportnet


SUCHE

Gruppen im Forum
Betriebsysteme
Software
Hardware
Netzwerk
Programmierung
Sonstiges

Impressum © 1997-2015 SupportNet
Version: supportware 1.8.230E / 18.10.2010, Startzeit:Mon Aug 21 21:20:21 2017