Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

excel verschachtelung SVERWEIS SUMMEWENN WENN





Frage

Hallo, ich habe folgendes Problem: ich möchte verschiedene Spalten als Kriterien durchsuchen und dann daraus eine Summe aus einer anderen Spalte erhalten. Die erste Spalte untergliedert sich nach Kategorie Familie, Freunde, Bekannte, sonstige und Kollegen Die zweite Spalte untergliedert sich nach verschiedenen Orten wie z.B. München, Hamburg Die dritte Spalte enthält ein Datum, das entweder als 01.01.2099 um die Dateien unbefristet behalten zu können gekennzeichnet ist. Oder sie enthalten ein normales Datum, um nach gewisser Zeit die Dateien überprüfen zu können und teilweise wieder löschen zu können, die ein normales Datum tragen. Die vierte Spalte enthält eine Zahl, die ich gerne addieren möchte, sofern die drei anderen Kriterien so lauten, wie ich in den Feldern x y und z angebe. Ich weiß nicht, ob mir da jemand helfen kann, aber ich komme so einfach nicht weiter. Vielen Dank schon mal. Christian

Antwort 1 von Aliba

Hi Christian,

=SUMMENPRODUKT((A:A100=X1)*(B1:B100=Y1)*(C1:C100=Z1)*D1:D100)

Falls die FOrmel irgendwie hin- und herkopiert wird, dann die Bezüge absolut machen (z.B: $A$1:$A$100)

Bereiche auch Deine Gegebenheiten anpassen.

CU Aliba

Antwort 2 von 5163130

Vielen Dank schon mal für die Hilfe, aber leider glaube ich funktioniert das noch nicht so ganz.

Die Tabelle erzeugt immer ein "Nr. Zahl!"

ich glaube, dass das vielleicht funktioniert, wenn man nur Zahlen zur Verfügung hat, aber nicht mit verschiedenen Wörtern.

Mit Summewenn, Wenn, Summe, oder SVERWEIS geht das nicht vielleicht, oder?

Antwort 3 von rainberg

Hallo Christian,

könnte es sein, dass es deshalb nicht funktioniert, weil Aliba in seiner Formel eine 1 vergessen hat?

Richtig wäre:

=SUMMENPRODUKT((A1:A100=X1)*(B1:B100=Y1)*(C1:C100=Z1)*D1:D100)

Oder hast du deine Kriterien anstelle der Zellen X1; Y1; Z1 in anderen Zellen stehen?

Gruß
Rainer

Antwort 4 von 5163130

Hallo Rainer,

nein leider ist das nicht der Fall. Die Kriterien stehen schon an anderer Stelle, aber die habe ich schon richtig mit einbezogen.

Ciao Christian

Antwort 5 von rainberg

Hallo Christian,

kann es sein, dass das Zellformat der Spalte C nicht mit dem der Zelle, in der das Suchkriterium steht, übereinstimmt.

Will sagen nicht alles was wie ein Datum aussieht, ist auch ein Datum sondern könnte auch Text sein.

Die Formel an sich ist schon ok.

Gruß
Rainer

Antwort 6 von 5163130

Vielen Dank.

Jetzt hat es funktioniert.

Christian

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: